Upgrading ASA 5500 Series firewall, things to be considered – Series 1

When it comes to upgrade an ASA 5500 Series firewall from 8.2 version to 8.3 or so, many things comes into the picture.  Recently we upgraded our ASA 5540 Firewall from the IOS version 8.2.1 to 8.4.6. I would like to share the details about the upgrade.

Stating IOS version 8.3 and later there is pre-requisite related to memory of the ASA. Most of new ASA manufactured after Feb 2010 comes with the upgraded memory. However if your ASA was manufactured before February 2010 you may need to upgrade the memory of the ASA as per the below mentioned table.

* Note:  The maximum memory supported for the ASA-5520 and ASA-5540 is 2 Gb.  If you install 4 Gb of memory in these units, they will go into a boot loop.

The first thing you need is to determine the existing memory your ASA has , which can be done in two ways first by using a command line interface (CLI) do issue a command show version | include RAM …….. Read  more…………………

Leave a Reply